Software feedback > UCheck

ucheck tech version issue with scripting

(1/2) > >>

brannanit:
So I am trying to use ucheck on my domain. I made a PS script that does what I need, it all works. But the license is the issue. Everything works ONCE, but then I have to log into the portal and manually deactivate the license to use on another machine. I figure either I'm doing this 100% wrong (using a PS script I push out to the machine instead of somehow running everything on my machine?) or there is a way to handle the license issue? It's just me, 1 tech, but I want to automate ucheck on my domain, and I can do this if there is a way to deactivate the license with a command or perhaps run it from my machine, on their machine?

Curson:
Hi brannanit,

Welcome to Alice.com.

I assume you are using your PS script with UCheckCMD as the target.
At the moment, it's not possible to generate temporary Premium licenses from UCheckCMD, which you will need to use with the "-activate" command line option on the remote device.

Please see : https://www.adlice.com/docs/ucheck/premium/technician/

I will ask our main developer, if it's possible to add this feature to UCheckCMD.

Regards.

brannanit:
Thank you!

I guess I'm wondering how you would run ucheck (technician) on more than 1 machine without having to manually deactivate the license each time. If it's not possible that's fine but adding this feature would be a huge benefit.

Curson:
Hi brannanit,

At the time being, you have to manually generate portable licenses using UCheck (GUI version) :
https://www.adlice.com/docs/ucheck/premium/technician/#generation

Then, you can use your PS script to deploy them on the machines on your domain. Since you don't use your own license you don't need to deactivate them after use.

Regards.

brannanit:
Thank you, I will look into this and see if I can make it work. If I have great success I will document here. Thank you!!

Navigation

[0] Message Index

[#] Next page

Go to full version